Jump to content
Do Not Sell My Personal Information


Car Not Getting Up To Temperature!


Karma Supra
 Share

Recommended Posts

The supra is not getting to its proper running temperature!

After letting it idle for AGES.. and giving it a good run the temperature guage was still near the "cold" mark... Any ideas people?

Link to comment
Share on other sites


Reminds me of the Skoda Estelle I used to own (I have no shame!). The thermostat had been removed so I used to have to wear wooly gloves in the winter whilst driving. I'm told that this was to stop the head gasket from blowing, I later fitted a thermostat and the head gasket blew about 1 month later :blink: so I guess the original owner was right :( .

Link to comment
Share on other sites


Get a proper Toyota one. I had one from Halfords that didn't work very well - just changed it for a Mr T one last weekend and all is now fine and dandy. And unless the coolant is A OK and you can collect it then budget for replacing that as well - get the red stuf again from Mr T

Link to comment
Share on other sites

I always do use 4life red.... however when turbo technics changed the coolant they put in anti freeze and water :blink:

I doubt halfrauds do one that fit my car lol.. Toyota it is.. cheers people.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership