Jump to content
Do Not Sell My Personal Information


  • Join Toyota Owners Club

    Join Europe's Largest Toyota Community! It's FREE!

     

     

Rav4 Cooling Fans


tatteam
 Share

Recommended Posts

Hi there guys, I owe a 2006/7 Rav4 and having problems with cooling sys. The level in the expansion tank is being lowered under the low limit, from the tank pressure releive valve, the fans seem not to work. With AC on fans works but as soon I switch AC off fans will turn off. The temperature is being kept just above half position and water can be seen bubling inside expansion tank and fans remain off. Toyota dealer instruct me to change tank cap, but to no avail. Checked relays and fuses and even tried to bypass temp switch but still didn't work. ANY CLUE :(

Link to comment
Share on other sites

I'm afraid that could be bad news. RAVs of that era had the potential to have cylinder head gasket problems. In this country it is possible that Toyota will honour warranty claims but we have seen that you can have problems in Malta.

However, I would approach them and ask for a policy warranty claim.

Good luck.

Link to comment
Share on other sites

Hi, thanks for the advice, I'll try to contact Toyota Dealer in Malta and try my luck, hope its nothing that serious :crybaby:

Link to comment
Share on other sites

Hi, finally problem seem to be solved. It was an air lock in the system which I realized when I squeezed the hoses through and from radiator. I removed the hose feeding the reservior and squeezed the hose feeding the radiator so to bleed air out, topped out the radiator through the hose I removed from the expansion tank and system was filled perfectly. Now all is working fine and I'm Happy to have my Rav OK :yahoo:

Link to comment
Share on other sites

Hi, finally problem seem to be solved. It was an air lock in the system which I realized when I squeezed the hoses through and from radiator. I removed the hose feeding the reservior and squeezed the hose feeding the radiator so to bleed air out, topped out the radiator through the hose I removed from the expansion tank and system was filled perfectly. Now all is working fine and I'm Happy to have my Rav OK :yahoo:

:thumbsup:

Link to comment
Share on other sites


Hi, finally problem seem to be solved. It was an air lock in the system which I realized when I squeezed the hoses through and from radiator. I removed the hose feeding the reservior and squeezed the hose feeding the radiator so to bleed air out, topped out the radiator through the hose I removed from the expansion tank and system was filled perfectly. Now all is working fine and I'm Happy to have my Rav OK :yahoo:

Congratulations - yoov become an expert!

(Wish I was in Malta - love Gozo and the weather!)

((Hold that result... just seen a bit of blue sky here in Glasgow!))

Link to comment
Share on other sites

Latest Deals

Toyota Official Store for genuine Toyota parts & accessories

Disclaimer: As the club is an eBay Partner, The club may be compensated if you make a purchase via eBay links

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share







×
×
  • Create New...




Forums


News


Membership