Sign in to follow this  
jongy

Diesel Starting Problem

Recommended Posts

I have a 53 plate Avensis Diesel that won't start. When turning the key in the ignition I am getting an electrical buzzing sound which cuts in and out and seems to be coming from the fuse box under the bonnet.

The engine is not turning over at all when I try to start it; it's completely dead. The Battery appears ok - headlights are not dimming when ignition turned, etc. I'm wondering if this is something to do with the glow plug fuse or relay. Can someone point me in the right direction? Thanks.

Share this post


Link to post
Share on other sites

Quite possible the ignition switch is faulty, the part on the back of the key/barrell, quite common on Avensis

Kingo :thumbsup:

Share this post


Link to post
Share on other sites

Hi jongy,

To me, it sounds like your starter motor is dead. It's located on the side of the engine fly-wheel. So you might need to replace it.

Dead glow plugs won't stop a car turning over when you turn the key in the ignition. Or as suggested earlier, the ignition barrel might need to be replaced.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this