Sign in to follow this  
etihad

Compressor Slower After Ecu Reset?

Recommended Posts

ok, so I reset my Compressor ECU the way its supposed to be done, and everything went fine. Came to drive it, and I noticed the car is a tadd slower, It might be physcological..lol but I dont know but I'm sure before on first gear it used to pull harder.

I'm thinking because it has a K&N sticker on the filter maybe I had wiped out a previous re-map maybe? But then if i did, then the engine light would of come on becuase it would be detecting too much air maybe?

Another thing there used to be a slight knock before when i put my foot down the knocking has now gone, and only got it once when accelerated at 3rd gear revs were around 2000. Also i noticed now when i put my foot down in first gear before it used to jump and accelerate, now it's more of a smooth constant acceleration which doesn't feel as fast but again I don't know if I'm just exaggerating.

So please help you think I'm just panicing like a little boy? or maybe I have actually wiped out a re-map?

Share this post


Link to post
Share on other sites

Sounds like it might have had the wrong fuel in and by resetin the ecu its stopped the engine from pinking. I would make sure it has a full tank of super unleaded then reset ecu again.

Share this post


Link to post
Share on other sites

well when i picked it up from the dealer i put bp ultimate. I fuelled up with v-power yesterday and reset it today.

Share this post


Link to post
Share on other sites

ok, so I reset my Compressor ECU the way its supposed to be done, and everything went fine. Came to drive it, and I noticed the car is a tadd slower, It might be physcological..lol but I dont know but I'm sure before on first gear it used to pull harder.

I'm thinking because it has a K&N sticker on the filter maybe I had wiped out a previous re-map maybe? But then if i did, then the engine light would of come on becuase it would be detecting too much air maybe?

Another thing there used to be a slight knock before when i put my foot down the knocking has now gone, and only got it once when accelerated at 3rd gear revs were around 2000. Also i noticed now when i put my foot down in first gear before it used to jump and accelerate, now it's more of a smooth constant acceleration which doesn't feel as fast but again I don't know if I'm just exaggerating.

So please help you think I'm just panicing like a little boy? or maybe I have actually wiped out a re-map?

as far as i know, there's little to be done with the compressor/t-sport in the way of remaps, so it would be highly doubtful that you would have wiped one.

drive it hard for a couple of days to let the ecu get used to your driving style, and i'll bet the car will start to feel quick again. the ecu takes a wee while to gather info and start delivering fuel appropriatley, so a couple of days of hammering the b-roads should do the trick lol.

the supercharger smoothes out the sensation of lift, so don't be worrying about that - it actually sounds like it's running the way it's supposed to...

Share this post


Link to post
Share on other sites

Thats makes alot of sense, if the ECU has to get used to my driving then thats fine, but I never knew the ECU did that, I only though it monitored info for the car only.

What I mean by jumps, if I was at the trffic lights in first gear, when i slowly lifted my foot of the clutch and applied the accelerator i pressed it abit too much the car would accelerate faster compared to now; where it's a smoother acceleration. If it's due to the ECU getting used to my driving like you mentioned I guess that will be back soon?

Share this post


Link to post
Share on other sites

Good news, the cars fine, came to work today car was driving normal. Thanks

Share this post


Link to post
Share on other sites

Good news, the cars fine, came to work today car was driving normal. Thanks

happy days. all going well, after a couple of runs it should start to feel quicker than before. just stick to v-power fuel and let it get rid of what was in before...

Share this post


Link to post
Share on other sites

any time...

Share this post


Link to post
Share on other sites

Hi guys , just noticed this topic. And seems that I only recently bought my Compressor , should I be resetting the ECU also ? To get use to my driving style also?? It does seem to be sounding a bit "rough" some times , could this be that the previous owner didn't fill up with Super Unleaded everytime , and pinking has occured ?? I always have filled with either V-POWER or BP-Ultimate since I've owned it. Would a bottle of REDEX or something in the tank before filling help this ? :blink:

Share this post


Link to post
Share on other sites

Hi guys , just noticed this topic. And seems that I only recently bought my Compressor , should I be resetting the ECU also ? To get use to my driving style also?? It does seem to be sounding a bit "rough" some times , could this be that the previous owner didn't fill up with Super Unleaded everytime , and pinking has occured ?? I always have filled with either V-POWER or BP-Ultimate since I've owned it. Would a bottle of REDEX or something in the tank before filling help this ? :blink:

BP Ulimate is only 97 ron so should not be used as the Compressor requires at least 98 ron fuel. Its probably back to safe running.

Share this post


Link to post
Share on other sites

Ok , so does that mean that I'm going to need to reset it to get the most of it and use V-POWER everytime. Bare in mind I only used BP once I think, I'm just concernd that previous owner didn't use high octane fuel.... :ffs:

Would resetting the ECU help at all ? :blink:

Share this post


Link to post
Share on other sites

resetting the ecu simply puts the 'learning' side of the ecu back into full power mode. if you then drive like a granny it becomes a touch more frugal, drive enthusiastically and it stays as such. If it feels sluggish, reset it, its easy enough to do. If you dont want to reset it, then its no issue.

BP ultimate does officially suck the big one. Im sure its fine in some cars but has never felt right in the CTS. Tesco's 99, or as they now label it 'Momentum' all the way.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this