Sign in to follow this  
ctbear

Oil Light Is On After Recently Oil Change

Recommended Posts

Hey guys I have a 2001 RAV4 2WD

Last week when I was getting home, when I started the car, the Oil light came on and I heard loud rattling noise from the engine .

I figured it was about time for an Oil change (3000 miles since last change) so I went to a local Meineke next morning .

They changed the Oil and filter for me, but as I was driving away the Oil light came back on again .

So I talked to the technician and he explained that since the light was already on before I took it there, it's probably due to some other problems. I checked the dipstick myself and it looks clean and have enough Oil in there.

I notice that after a cool down, the Oil light would not come on until a few minutes after I start driving. Occasionally it produces a brief rattling noise but it goes away quickly.

No idea what's wrong since I don't know much about cars. When I bought it in January this year, it had the exact same issue but it went away after a second Oil change, 2 days after the 1st change.

Could it be the cold weather or the kind of Oil Meineke used? What should I do at this moment?

(The maintenance light is not on, just the Oil light.)

Share this post


Link to post
Share on other sites

I'd kind of guess that theres a problem with the Oil pressure - maybe the Oil pump? Whats the mileage on the car?

Share this post


Link to post
Share on other sites

I'd kind of guess that theres a problem with the oil pressure - maybe the oil pump? Whats the mileage on the car?

119K as of right now, it was 112K when I bought it.

Share this post


Link to post
Share on other sites

things to check would be the grade of Oil they have used - is it too thin a type...maybe the garage compensating for cold weather??

I find it common for the Oil pressure to take a few seconds to build up from starting from cold. However if its taking longer then I'd discount a sensor problem as you mention the engine is rattling.

I'd try to get it checked by a garage where they can measure the Oil pressure when running -

Is it losing/burning Oil?

I have to say that I'm not that knowledgeable on the VVTi engine - but the symptoms you describe don't sound too healthy. Unless the rattling is just after start up. If the rattling is when you have been driving then I would get the engine checked. If the rattling is only on start up, then its no big deal as long as you don't rev the engine.

I've read that synthetic Oil is good for more modern engines - I use semi-sync and seems ok just now.

Share this post


Link to post
Share on other sites

The light is usually off from a cold start. However it will come back on after the engine runs for a few minutes. From what I understand, if the Oil takes time to build up pressure in cold temperature, shouldn't it be the opposite? (light up when start, goes off after a while)

On the receipt it says they used 5 qt of "synthetic blend" Oil.

I will probably find some time to call them again tomorrow and see what they can do about it.

Share this post


Link to post
Share on other sites

ye - your right - light on first then goes off.

The synthetic Oil is meant to stick to the bearings etc better so reducing wear and so on.

I'd get it checked again by the garage.

There are a few stories of Oil excessive use on this engine but I haven't seen any re the pressure. Maybe someone else with knowledge of this engine will come along soon....

Share this post


Link to post
Share on other sites

Hey guys I have a 2001 RAV4 2WD

Last week when I was getting home, when I started the car, the oil light came on and I heard loud rattling noise from the engine .

I figured it was about time for an oil change (3000 miles since last change) so I went to a local Meineke next morning .

They changed the oil and filter for me, but as I was driving away the oil light came back on again .

So I talked to the technician and he explained that since the light was already on before I took it there, it's probably due to some other problems. I checked the dipstick myself and it looks clean and have enough oil in there.

I notice that after a cool down, the oil light would not come on until a few minutes after I start driving. Occasionally it produces a brief rattling noise but it goes away quickly.

No idea what's wrong since I don't know much about cars. When I bought it in January this year, it had the exact same issue but it went away after a second oil change, 2 days after the 1st change.

Could it be the cold weather or the kind of oil Meineke used? What should I do at this moment?

(The maintenance light is not on, just the oil light.)

Share this post


Link to post
Share on other sites

Hi,

I think you have problem with the Oil pump, either the Oil passage is block or the pump it self not pump properly, I have exactly the same problem on the old Suzuki Vitara V6 engine, it may due to the different Oil type mix togheter (synthesis and mineral) then in high temperature it creates some big junk of dust just like flake some time as big as 4x4 mm enought to clog the Oil passage and make the engine starve of Oil, do not drive your car to much it may cause the engine worn out due to lack of Oil, the good thing is the pump may still work therefore when the engine cold, the Oil still thick, dust sink in the bottom of the resevoir the pump can create hight presure and pump throught so the light stay off, when the engine hot the Oil thiner, the pump work faster and bring up dust and limit the Oil thru put, so the engine will lack of Oil. Try to use the engine flush to clean it. hope this help you.

Share this post


Link to post
Share on other sites

Thanks for the suggestions.

I had to drive to school today. This time the Oil light stayed on and never goes off anymore. I heard constant rattling noise which was very worrying. Then after a while the car seemed to have lost power (accelerates slowly).

I have scheduled for another Oil change plus engine flushing tomorrow. Or should I do something else at this stage?

Share this post


Link to post
Share on other sites

Thanks for the suggestions.

I had to drive to school today. This time the oil light stayed on and never goes off anymore. I heard constant rattling noise which was very worrying. Then after a while the car seemed to have lost power (accelerates slowly).

I have scheduled for another oil change plus engine flushing tomorrow. Or should I do something else at this stage?

I think you have got past the stage of changing Oil now. Take it to a proper mechanic and not one of the fast fit Oil change centers. You need good advice before you waste any more money. I think it might be adviseable to call them out rather than run it any more. If it is fundamental - and I think it is, you are ruining your chances of ever getting it fixed each time you drive. That sounds like an engine job to me.

Good luck.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this