Sign in to follow this  
Glasswarrior

Egr Valve Trouble Or Something Else?

Recommended Posts

HI,

I have a 2003 Avensis T-Spirit D4D. The engine has been faultless since I bought it over 2 years ago but just recently has been showing an intermittent fault. When accelerating (almost always from low speed like moving off etc) there is a lack of power then suddenly power surges to normal with billows of black smoke. This occurs mostly intermittently but sometimes persistently and can disappear for a few days then reoccur.

I have put some injector cleaner through (do this reasonably regularly anyway) and done the driving like a mad man at high revs thing which seemed to help for a few days. The car is used by my wife mostly for local scoots and a commute of 20 miles per day and rarely gets a fast run anywhere until I get it at weekends/evenings.

I've been reading some posts here about what appear to be the same symptoms caused by a blocked EGR valve. Thinking it would be worth cleaning it out as a first step? Anyone feel it may be something else? Mileage is 120000.

A few days ago my brother in law put his diagnostic on her and got a code of P0380. He doesn't have Toyota fault codes, anyone know what this means?

Any wisdom gratefully received!

Cheers

Share this post


Link to post
Share on other sites

120000 miles is something

have EGR cleaned and try to be a mad man again to see the result interested for us.

regards / igor

Share this post


Link to post
Share on other sites

The EGR valve clean is quick and easy and for a car of that age probably very welcome. I did it on a 105k 2006 T180 with some dead acceleration and it's now a peach. Do it fella!

Share this post


Link to post
Share on other sites

This morning I started following the instructions at this link:

www.toyotaownersclub.com/forums/index.php?showtopic=114711

Got to the part where I had to undo the bottom bolt on the valve but, due to pipes and cables, although I could feel it ok I couldn't get a socket onto it. I decided discretion was the better part of valour and withdrew. Don't want to fight to get it off then find I can't get it back on. I'll have a think and try again next weekend. Noticed the air filter is very dirty though only replaced just over a year ago so I'll change that anyway and maybe try some system cleaner through her again in the meantime.

cheers

Share this post


Link to post
Share on other sites

Admittedly it was awkward to get a socket locked on but with the right combo of extensions it's possible.

Share this post


Link to post
Share on other sites

I'm gonna try some BG244 additive as recommended to me. If no joy I'll revisit that bolt and try to borrow some different extensions. It's certainly an awkward one but I can see you are right, apart from that bolt it is fairly straightforward.

cheers

Share this post


Link to post
Share on other sites

Hi

You can try all the fluids you like but the only way with the EGR is to strip it off and clean it out.

Share this post


Link to post
Share on other sites

Thanks Revband and you are likely right but I bought a can of that BG244 and put it in with some BP Ultimate diesel ( I normally buy ASDA stuff as it's the best priced around here) and I'll give it a whirl. I understand what you're saying and you can feel free to tell me you told me so if/when I have to actually pull it out and clean it. But I'm viewing this as a knowledge gaining exercise also, so that I can also advise others from personal experience.

The cat has actually been driving fine this past few days. I know that can mean nothing but I'd like to try this fluid anyway. Believe me, if it doesn't work not only will I admit it but I'll be telling the company pointedly that their stuff is crap!

I've got a sick motorbike too so must go and tend to her. Battery or charging system trouble. Thanks for your help everyone, will let you know what happens next!

cheers

Martyn

Share this post


Link to post
Share on other sites

WEll, got the BG244. Added it as per instructions and wow, after a few days the difference is noticeable, honestly. It's been a week now and there has been no problem, in fact the car runs sweeter. NO visible soot AT ALL upon hard acceleration, mpg is a bit better and pick up is better especially in higher gears.

The manufacturer mentioned my problem as one of the issues this fluid would address but made no wild promises. I'm happy with the result. Hopefully save me a fiddly job! I'd recommend anyone with similar issues to try it, or even just try it anyway. I was definitely sceptical but not now.

Thanks to all for their input, it is much appreciated.

Share this post


Link to post
Share on other sites

Quite a few of us on here have been singing the praises of BG244 for a while now. Glad its worked for you :drunk::driving:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this