Sign in to follow this  
PatW

Pwr Mode Button Not Working

Recommended Posts

Hi all - I just noticed today that the PWR mode button on my Prius no longer works. When I press it nothing happens at all - no PWR light on dash and no change in throttle response. Eco and EVO buttons still work fine.

I don't use it very often but it was working last time I tried a few months back.

Is there anything obvious I have missed before I take it to Toyota for them to take a look?

cheers

Patrick.

Share this post


Link to post
Share on other sites

Can't think of any situation that would prevent PWR mode operating, it must be faulty, could be the switch.

Share this post


Link to post
Share on other sites

Faulty switch or faulty connector are the most likely.

Share this post


Link to post
Share on other sites

Had the same problem on my Auris, connector failed, they sorted it in about 25mins and got me on my way full of caffeine :-) must say always been very lucky with my local dealer.

Share this post


Link to post
Share on other sites

Never pressed mine and not likely to either, it’s a stupid addition on a car built for economy.

I drive 90% of the time in eco mode and when I do venture out onto the motorways I just switch it off and let the car run in normal mode.

Share this post


Link to post
Share on other sites

I have heard of someone else with same issue and turned out to be the PWR switch issue

Share this post


Link to post
Share on other sites

Never pressed mine and not likely to either, it’s a stupid addition on a car built for economy.

I drive 90% of the time in eco mode and when I do venture out onto the motorways I just switch it off and let the car run in normal mode.

Go on, press the PWR. You don't know what you're missing.

I normally drive in ECO but do use PWR from time to time when more power is needed. The honourable example is when I'm joining fast-moving traffic and don't want to hold people up while i accelerate. The less honourable example is when I have chosen the wrong lane at lights and use PWR to beat the other traffic.

ECO does work well on motorways provided you are travelling at a steady speed.

Share this post


Link to post
Share on other sites

I only use it to pull away a little quicker from a standing start. Normal mode I find is as quick and less noisy when i'm already moving.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this