Sign in to follow this  
Teddyteddy

Air Bag Indicator

Recommended Posts

Few months ago the Air-bag indicator light flashed,.discovered loose wires under passenger seat, taped it up,.flashing stopped. however the Air-bag indicator has started flashing again, although this time I can not see any loose connections, is it safe to drive car? Id be grateful for any help with this, thanks.

Share this post


Link to post
Share on other sites

I cannot comment on whether the car is safe to drive - nobody will advise on that from a long distance.

I suggest you keep looking for loose wiring under both seats and anywhere else you can trace the wiring. I had a similar problem with a Renault Megane and ended up removing the seats to check the wiring. I pulled apart the connectors and re-connected them a few times, looked around for broken or damaged wiring and couldn't find anything.

I put the seats back, switched on and started the car - the airbag lights went out and stayed off. The problem disappeared and never came back.

Hopefully someone with exceptional Aygo experience will be along soon to help you. Good luck...

Share this post


Link to post
Share on other sites

Hi,.thanks for taking time to reply,.ill do a more thorough check of the wiring, hopefully find the problem,.thanks again.

Share this post


Link to post
Share on other sites

perhaps spraying the connectors with contact spray before re connecting will help?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this