Sign in to follow this  
UK_Messer

Sat Nav And Info Not Connecting

Recommended Posts

Hi Guys I'n new to this forum melarky but I have a fault with my Sat nav.

I have a Toyota Corolla Verso T-Spirit 2001/2 on a 51 plate.

My problem started back in May when we went on holiday and were driving down to Devon, for no reason the radio crackled and went off line all the pre set channels disappeared and we couldn't tune into any channel on LW, MW or any of the FM channels.

The CD worked fine also the sat nav was still displaying our location and working fine, I was able to use the sat nav for finding places of interest etc. Besides the exhaust splitting (£480) of our holiday dosh gone all was working well except the radio.

Upon our return home I spoke to a mechanic and although he said he's not an audio specialist he suggested disconnecting the Battery for 24hrs to reset the system this I did and the radio now works perfectly.

I had trouble with an engine management light coming on but this was a lambda sensor problem in conflict with the new catalytic converter which has corrected itself now.

After a month I went to use the Sat Nav but I got a message stating it cannot connect to the system (I'm writing this at work so don't have the correct wording but will post later) I'm not sure if the above would be a part of the problem but thought I should include it anyway for the 'history' of the car.

The sat nav system was fitted new by Toyota as an optional extra upgrade for the previous owner. It is a CD, Tape, Radio and Sat Nav system set in the center of the dash I also get the message when I press the 'INFO' button on the system.

Has anyone come across this problem if so what is the fix?

Thanks for reading this far and I hope someone out there in Toyota land can help

Regards

UK_Messer

Share this post


Link to post
Share on other sites

tbh SatNav has advanced so much over the last 13 years that I would suggest that you get an inexpensive Garmin/TomTom etc. & use that instead.

The map data update alone from Toyota would probably cost more.

Share this post


Link to post
Share on other sites

Heidfirst thanks for the comment I appreciate that it is an old system but if I could get it working it would be nice as having something mounted on the dash thats not functioning is a bit naff... I certainly don't relish the prospect of going to Toyota and paying them silly money if someone on the forum can help.

The message I get on the display is

"The external system is not connected"

so hopefully it will be a matter of resetting the system to reconnect it All I need to know is how to do it I hope someone on the forum can help

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this