Sign in to follow this  
r n s

estima lucida warning lights

Recommended Posts

we bought an estima lucida that needed we changed the starter moter on, but still the Battery keeps going flat. I was out 1 afternoon when the Battery went flat so my o/h came with jump leeds to get me going again. 

whilst driving it was very slow and sluggish  and I had no electrics. I drove home with most of the dash lights on. and now they arnt going off. we don't have the Battery connected at present.

now the Battery has been changed and we are still having the same issues. we can drive it but risk it not starting when we return to the car.

these are the lights that are constantly on when the Battery is connected 

a/toil temp

Oil change

Battery light

the orange symbol next to the Battery light 

the rear lights light

and the rectangle with lines in the middle {orange light } nect to rear lights warning light.

how do we find out what is draining the Battery and how to get the lights off the dash . 

any help appreciated 

thank you 

 

Share this post


Link to post
Share on other sites

Welcome to Toyota Owners Club.

Moved to the Estima club.

Share this post


Link to post
Share on other sites

Hello Richard, have you checked for any loose earth wires it could be a bad earth connection somewhere.

Share this post


Link to post
Share on other sites

all earth wires are fine . 

thank you for your reply 

Share this post


Link to post
Share on other sites

Can you get the Alternater tested anywhere?That might faulty.

 

 

Share this post


Link to post
Share on other sites

I have just put a new one on and still the same 

Share this post


Link to post
Share on other sites

Maybe it's worth investing in the services of a good auto electrician..might save time and money in the long run..?

Hope you get it sorted.

Share this post


Link to post
Share on other sites

I agree with Neil an auto electrician will be the best option.

Share this post


Link to post
Share on other sites

I have these exact warning lights showing. For me they appeared after I gave my van a good cleaning (including under the hood).

Did you ever get to the bottom of this issue?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this