Sign in to follow this  
ewanw

2000 Yaris Wash Wipe problem

Recommended Posts

Hi all

New here and I'm sorry to dive in with a question!

Long journey tomorrow in our 1.0 Yaris on a 'W' plate. and I have a problem which started today.  When pulling the wiper stalk toward me the wipers wipe but there's nothing coming from the washer reservoir and no noise from the washer pump.  Loads of water in the reservoir and the rear wash/wipe is fine with water coming from the rear nozzle and a dribble (as usual) from the front nozzles when I twist the end of the stalk forward.

If anyone can offer any advice I'd really appreciate it - desperate!

Thanks :-)

 

Share this post


Link to post
Share on other sites

Check the fuses, if they are ok, then check the pump connections, try to wiggle a bit, if nothing, take the pump out, and connect directly to Battery to see if it works or not.

Share this post


Link to post
Share on other sites

Thanks.  Fuse fine and my car is the single pump version (pump is working for rear washer no problem). I'm wondering if it's the wiper relay?

Share this post


Link to post
Share on other sites

It is a single pump, but with 3 pins, so engine spins both ways, maybe the connection to one side is bad, so i'd still take it out and check manually.

 

Share this post


Link to post
Share on other sites

Ah OK, thanks 🙂

Share this post


Link to post
Share on other sites

Check the little holes in end of the jets, they can clog up with polish or dirt, before you do anything else.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Club Hybrid Poll

  • 219 Hybrid Reliability

    1. 1. If you were to consider buying a Hybrid model over 5 years old, would you be worried about the reliability of the Hybrid system?


      • Not really as Hybrid systems are always reliable
      • Not if it had a Manufacturers Warranty on the Hybrid system
      • I would not buy a Hybrid model over 5 years old