Sign in to follow this  
wozza_t

Previa 2.0 D4D revving issues

Recommended Posts

Hey guys, I am having more issues with the previa, it's not revving above 2k, and taking ages to get there. I have replaced the fuel, the SCV's and air filter, checked it over on the diagnostics and no faults or codes come up. I have cleaned the MAF sensor and seem to get good readings on that but the diagnostics show even with the accelerator fully down, it only shows its 78% open.

 

I'm not at a loss on where to go next....help?

Share this post


Link to post
Share on other sites

Moved to the Toyota MPV club.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Club Hybrid Poll

  • 218 Hybrid Reliability

    1. 1. If you were to consider buying a Hybrid model over 5 years old, would you be worried about the reliability of the Hybrid system?


      • Not really as Hybrid systems are always reliable
      • Not if it had a Manufacturers Warranty on the Hybrid system
      • I would not buy a Hybrid model over 5 years old