Jump to content
Do Not Sell My Personal Information


2004 2.0 d-4d pinging,tapping noise until high acceleration


Recommended Posts

Hi first time posting here.

I have a 2004 Avensis diesel 2.0 d-4d, the problem I'm having is rattle, pinging noise on cold start up that persists until high acceleration for a period of time.

I can accelerate to 2500 rpm in second gear and it will disappear, when I drop off the rpm it comes right back. Also to note when accelerating up to 2500rpm and the rattle stops there's a noticeable sudden boost in power. 

Weirdly enough if drive at high rpm the noise will disappear after maybe 5-10 minutes driving, but if I drive normally the rattle will persist even after 30mins of driving.

I'm wondering if it could be injectors, lifters, timing out? It's done 300000km/186000miles.

I was given the car a few months ago so I don't know the history, but I've given it an Oil change, fuel filter change etc

Love to hear any ideas,

Thanks.

 

 

 

 

 

Link to post
Share on other sites

Hi I have the same car, I've been reading up loads on them lately as I've had trouble with mine..

There is a common issue with injector seals, and the gases leaked causes blockages in the Oil pickup in the sump.

In my opinion this is a game changer and will save you money if you can clean out sump and pick up and then change injector seats and o rings .. I was too late.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...




Forums


News


Membership