Jump to content
Do Not Sell My Personal Information


New Throttle body issue


Recommended Posts

So I had a new throttle body fitted and Maf sensor by a friends garage, i bought the throttle body from Germany and new maf, the car ran fantastic for a week then revs where erratic at idol. Now I have checked all the pipes for loss of vacuum checked all connections all fine, It throw a code P0505 idol air control system and engine check light today whilst at traffic lights near my home, anyone have an idea what I can do next? 

Link to post
Share on other sites

There is no where i can find info on re-learn on TPS for a Toyota just undid neg lead on Battery for 10 mins, re connected ,turned on ignition twice without switch on, third time pumped accelerator 5 times then started car, left for 5 mins to relearn idol which is now 800. But when i take for a drive the revs go up to 1200 when i come to a stop at lights and depress clutch, it will then idol back to 800??

Link to post
Share on other sites

Wondering if the air intake manifold gasket is leaking even though i have tested it and seems ok,have looked at youtube vids and some people have fixed their same issue, Maf new, Throttle body new,  air filter new, checked all the pipes???? Lost for ideas. 

Link to post
Share on other sites

10 hours ago, Deggs54 said:

Wondering if the air intake manifold gasket is leaking even though i have tested it and seems ok,have looked at youtube vids and some people have fixed their same issue, Maf new, Throttle body new,  air filter new, checked all the pipes???? Lost for ideas. 

Have you removed the intake manifold new gasket should be used, if you have not use a new gasket that may cause you a problem. You may need to use a new gasket for the throttle body too if you haven’t. What happens usually very likely related to the vacuum leak. , wrongly fitted gasket can also lead exactly to this issues, don’t ask me how I know 🤭😂👍

Link to post
Share on other sites

Tony

Funny you should mention this, not removed the intake manifold but today when I checked the bolts they were loose ? , so I have tightened them up and OMG the car runs so sweet...🤩

  • Thanks 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...




Forums


News


Membership