Jump to content
Do Not Sell My Personal Information


Caller Display


Mark Rose
 Share

Recommended Posts

Hi

I have a new Rav 4 PHEV. i have paired my phone and all contacts are in there but when a incomming call comes in it just shoes the telephone number. i have tried delting and repairing several times but still same. we bought 2 of these cars at the same time and both are the same.

Any body any idea how to fix this?

 

Mark

Link to comment
Share on other sites


I had a similar problem with my C-HR when connected to my iPhone X. 

I noticed that when some contacts called it would show all their details, and when others called, it would show only the number. I have had to re-programme all the numbers in my phone to the format 07777 777 777 rather than +44 7777 777 777

I then had to switch the phone off and then on to reboot everything. Then I connected to the car via bluetooth and uploaded my contacts to the unit.

This seemed to sort out my issue.

 

  • Like 1
Link to comment
Share on other sites

Big D, thanks for that that solution it really useful - NOT.  Thanks Toyota, do you mean I have to reprogram my phone every time I go overseas. 

I find the phone works well but its handsfree calling sucks.  I have yet to get it to recognise a name. 

Same with Navigation.  If I want to route to a town I can't just as TOWN, it insists house number, street address etc. If there is no number or street you're stuffed.  For a village I tend to go for 1 High Street or use the next Village Road. 

Link to comment
Share on other sites

5 minutes ago, Roy124 said:

Big D, thanks for that that solution it really useful - NOT.

I'm only telling you what worked for me.

  • Like 3
Link to comment
Share on other sites


Big D, no criticism of you but of the software.  If my phone can manage 0, 0044 and +44 it is obvious that their programmers haven't figured out how to create a proper number picture. 

 

  • Thanks 1
Link to comment
Share on other sites

Roy124, I tend to agree with you. I should be able to save the contact numbers in my phone any way I want. However, since I amended all my contact numbers, my unit now recognises names, plays the relevant ring tone for the contact, and shows the photo assigned to the contact.

As a matter of interest, are you using an Android or iPhone.

Link to comment
Share on other sites


Just store all numbers without +44. I'm fairly sure Android phones have international dial assist which will automatically add the +44 and remove the leading zero when roaming.

  • Thanks 1
Link to comment
Share on other sites

11 hours ago, Big_D said:

Mines an iPhone. I wonder if the phone settings have something to do with this?

1293658204_PNGimage.thumb.png.bd6d70e8cd154b001822074774750b59.png

Dial assist. I’ve been storing numbers in international format for years. There’s always the remote possibility that the phone will get the international code wrong, particularly when roaming near international borders and your phone switches from, say Switzerland to France, or vice versa.

  • Like 1
Link to comment
Share on other sites

1 minute ago, Roy124 said:

Must try the automatic when we are away.  Don't have dial assist on my Android. 

Yes, I should have been more precise. it's an IOS 15+ feature, but for all I know has existed for some time. I've just recently switched from Android to IOS. TBH there's no particular advantage to IOS over Android, and some things on Android are better, like separate volume for ringtones and notifications. IOS is only a better choice if the rest of your world is Apple, IMO.

Link to comment
Share on other sites

4 minutes ago, Roy124 said:

Must try the automatic when we are away.  Don't have dial assist on my Android. 

Try going in the phone app, press the 3 dot menu button, settings and it should be in there.

If it's on automatic, I think it changes for the prefix of the country you are in. You can set it for any country you want so set it for UK if you always want it to use +44.

Link to comment
Share on other sites

10 hours ago, nlee said:

Just store all numbers without +44. I'm fairly sure Android phones have international dial assist which will automatically add the +44 and remove the leading zero when roaming.

Mine doesn't. 

Link to comment
Share on other sites

My Android phone, Motorola e6play has assisted dialing. It's located on the dialing app (not the contacts app). Go to the three dots, settings, assisted dialing.

 

Link to comment
Share on other sites

5 hours ago, Stopeter44 said:

1293658204_PNGimage.thumb.png.bd6d70e8cd154b001822074774750b59.png

Dial assist. I’ve been storing numbers in international format for years. There’s always the remote possibility that the phone will get the international code wrong, particularly when roaming near international borders and your phone switches from, say Switzerland to France, or vice versa.

I've had a look at my phone, and dial assist is off. I'll turn it on and see if that makes any difference. As all my numbers are now stored in 07777 777 777 format I'll have to change a few and see if it works. Thanks Stopeter44.

Link to comment
Share on other sites

7 hours ago, Roy124 said:

Three things in the World to hate, Microsoft, Google and Apple 😁

Perm any one from three 

You're kidding (Not that much, I know), there's loads of reasons to dislike Microsoft, Google & Apple, but they have pretty good for technology, although I dislike the way we can be tracked across the internet. I like Apple because it's a one stop solution for pretty much everything.

Link to comment
Share on other sites

11 minutes ago, Roy124 said:

Google even provides a map of my dog walking routes, not very accurate though 

Do you have a GPS tracker for your dog ?

Link to comment
Share on other sites

2 hours ago, Stopeter44 said:

You're kidding (Not that much, I know), there's loads of reasons to dislike Microsoft, Google & Apple, but they have pretty good for technology, although I dislike the way we can be tracked across the internet. I like Apple because it's a one stop solution for pretty much everything.

A VPN can fix that 🙂

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership