ma109

Carine E Brake Lights

Recommended Posts

Hi all,

I wonder if somebody can advise me. For some reason both my brake lights have stopped working (although the high level one is OK). My questions are

(1) Why have both stopped working at the same time ? Is this coincidence or is it likely to be a wiring / fuse fault?

(2) How do i change the bulbs ? I have had a look in the boot but there does not seem to be any way to access the light cluster. However on the outside there are two hexagonal bolts which appear to secure the rear light cluster to the car body work. Am i right in thinking that these need to be removed in order to access the bulbs ?

(3) Are there separate bulbs for the stop light and the tail light or is it a single combination stop/tail light ? The tail lights are working fine so I'm assuming its separate bulbs.

Sorry to be asking such simple questions. I plan on fixing them on saturday and am trying to identify any problems which may crop up.

Share this post


Link to post
Share on other sites
 

I am in the same boat. Only, I have two large Phillips type screws which seem to be holding the rear cluster.

Only one stop light not working can anyone advise?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...