Sign in to follow this  
HankyPanky

Noise On Engine Braking

Recommended Posts

Lent the hi-lux to the son-in-law and it came back with this fault.

When the engine is pulling all is fine but as soon as I take my foot off the accelerator I am getting a nasty squeak/grinding noise.

Does anyone know the possible reason(s). Not clear where the noise is coming from but may be the prop-shaft....

Share this post


Link to post
Share on other sites
Lent the hi-lux to the son-in-law and it came back with this fault.

When the engine is pulling all is fine but as soon as I take my foot off the accelerator I am getting a nasty squeak/grinding noise.

Does anyone know the possible reason(s). Not clear where the noise is coming from but may be the prop-shaft....

Hi Hanky

I had a very similar noise when slowing/breaking and also when reversing,, it turned out to be a grinding UJ on the rear prop.when driving the prop is under pressure so the noise wasn't noticeable.I was fortunate enough to have 2 breakers sitting in my yard so the parts wern't a problem

Cheers

Paul

Share this post


Link to post
Share on other sites

yup, as siad prop uj... had to change a couple of mine for the same reason, also have a look at the rear gearbox mount, mine had broken, and i think this was the cause of the ujs failing

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this