Jump to content
Do Not Sell My Personal Information


  • Join Toyota Owners Club

    Join Europe's Largest Toyota Community! It's FREE!

     

Please Help, Car Can't Decide If It's Hot Or Cold


sega2k6
 Share

Recommended Posts

Hi,

got a P reg corolla si, driving about in it the other day noticed that the heaters were blowing cold even though the switch was set to hot and the temp needle was up. Not a problem i thought, let it cool, topped up the radiator and left the cap off for a bit while the engine ran to let out any air.

The heater now runs hot when i'm revving the engine or driving along the road but as soon as i stop and leave it to tickover the blown air goes freezing cold.

First question is will the car be alright to drive like this or should I leave it alone?

Secondly, what could it be and will it be expensive/difficult to put right?

Any help you could offer would be much appreciated, also it has the 1.6 4afe engine, if that means anything to you?

Thanks in advance

Sega2k6

Link to comment
Share on other sites

I am not sure if this will help but here goes, i had these symptons in the past and it was the heater matrix, which is horrible and expensive job. The car was fine to use it just had no heating!

If non of this helps then ignore it :)

Link to comment
Share on other sites

Hi,

got a P reg corolla si, driving about in it the other day noticed that the heaters were blowing cold even though the switch was set to hot and the temp needle was up. Not a problem i thought, let it cool, topped up the radiator and left the cap off for a bit while the engine ran to let out any air.

The heater now runs hot when i'm revving the engine or driving along the road but as soon as i stop and leave it to tickover the blown air goes freezing cold.

First question is will the car be alright to drive like this or should I leave it alone?

Secondly, what could it be and will it be expensive/difficult to put right?

Any help you could offer would be much appreciated, also it has the 1.6 4afe engine, if that means anything to you?

Thanks in advance

Sega2k6

Hi there,

sounds very much as if your thermostat has jammed which is not unusual and a pretty cheap fix I don't know your engine but most (stats ) are under a small bell housing with a hose coming from it if so a reasonably easy self fix but make sure you get the little gasket that should come with it

Link to comment
Share on other sites

Latest Deals

Toyota Official Store for genuine Toyota parts & accessories

Disclaimer: As the club is an eBay Partner, The club may be compensated if you make a purchase via eBay links

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share






×
×
  • Create New...




Forums


News


Membership