Sign in to follow this  
matt_tee

07 Plate Aygo Automatic (Stalling)

Recommended Posts

Hi,

Just bought 07 Aygo from reputible Toyota Dealer, Drove home and seemed a bit sluggish on auto change. When idle at lights, it felt as though it was going to cut out. This morning, reversed out of drive and the engine stalled, managed to start it but still driving sluggishly.

Anyone experienced this before?

Have spoken to toyota dealer, and am waiting for them to get back to me regarding returning the car for diagnostics.

Just thought someone here may have experienced the same.

Any ideas??

(Car was only bought yesterday! full mot/full service and a change of exhaust silencer box.)

The car is under 12 months parts and labour warranty provided by toyota.

Share this post


Link to post
Share on other sites

Hi,

Just bought 07 Aygo from reputible Toyota Dealer, Drove home and seemed a bit sluggish on auto change. When idle at lights, it felt as though it was going to cut out. This morning, reversed out of drive and the engine stalled, managed to start it but still driving sluggishly.

Anyone experienced this before?

Have spoken to toyota dealer, and am waiting for them to get back to me regarding returning the car for diagnostics.

Just thought someone here may have experienced the same.

Any ideas??

(Car was only bought yesterday! full mot/full service and a change of exhaust silencer box.)

The car is under 12 months parts and labour warranty provided by toyota.

As the vehicle is under warranty the dealer would need to download the latest software to the cars gearbox computer, this should fix the problem.

Share this post


Link to post
Share on other sites

a strange one, wonder if its mechanical (clutch) or purely the software?

Share this post


Link to post
Share on other sites

a strange one, wonder if its mechanical (clutch) or purely the software?

I guess its a sign of the times that software upgrades can sort problems out, some cars slip their clutch once its worn out and other just jam in gear, i don't know what an Aygo MMT does but if its stalling it could be the solenoids that release the clutch, so yes It could be mechanical......lucky its still under warranty :thumbsup:

Share this post


Link to post
Share on other sites

Hi,

Thanks for all the help, have now had the car into the toyota dealers and have found what they think the problem is. They have told me that is a faulty gearbox actuator, and that the technicians are going to repair under warranty.

Hope this solves the issue, will post back when resolved.

p.s

service from the dealership has been excellent so far, they have provided a courtesy car until own car is repaired. well done toyota!

Share this post


Link to post
Share on other sites

They have told me that is a faulty gearbox actuator...

Good stuff :) Diagnosis sounds plausible IMHO - make sure you give it a good test drive.

I love the MMT and think it is wonderful, although I'm not sure I will be as confident when our Aygo reaches 5Yrs+ and cannot have a Toyota Warranty...but that scenario is 4Yrs away ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this