Sign in to follow this  
gedk

Speedo Running Too Fast

Recommended Posts

My grandson stuffed someting down the cigar lighter port, which was "open", and it fused when the cigar lighter was put back. The radio stopped and the speedo started recording 50% faster than it should. After replacing the fuse the radio and cigar lighter work but the speedo is stil recording wrong. The garage offered the tought that a sensor might have gone. They advised to wait to see if it settled. It hasn't. Does anyone know the cause of this, please?

Share this post


Link to post
Share on other sites

Oops, not sure how to reply on this forum ...

Share this post


Link to post
Share on other sites

Sounds almost like it is set to Km/h rather than MPH. I know it sounds silly but has he tried changing between the two ?

Share this post


Link to post
Share on other sites

My grandson stuffed someting down the cigar lighter port, which was "open", and it fused when the cigar lighter was put back. The radio stopped and the speedo started recording 50% faster than it should. After replacing the fuse the radio and cigar lighter work but the speedo is stil recording wrong. The garage offered the tought that a sensor might have gone. They advised to wait to see if it settled. It hasn't. Does anyone know the cause of this, please?

hi gedk

how about leaving Battery disconnected for 5 mins,reconnect and see what you get.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this