Sign in to follow this  
Ianmozi

Lambda Sensor Problems

Recommended Posts

Hello All, Nightmare problem, but somebody can make the result easy, I have an Avensis Verso 2.0 7 seater 02reg. Started with having the Catalyst Converter changed(straight forward??) then the Mechanic had trouble getting the Lambda sensor out (top left as as you look in.) so i went and bought another one. NTK. cleared the EM & started up, 1 min later Fault came up P1155(P1155 A/F Sensor Heater Circuit Malfunction (Bank #2 Sensor #1) so had the mechanic check it again and still the same fault, so got an electrician to check and he said NO other faults found but the P1155, so ive gone out and bought another NTK, tried it.. and P1155???????????? So after browsing through the Internet and this forum, my only hope is to get an Original sensor, but to save money i would like to get it off the internet. tried some of the links in this forum for America, but they don't list the Avensis Verso, I Have a twin CAT & 4 sensors could somebody confirm that the Faulty sensor is the Top LHS as you look at the Engine? does somebody have another link/site they would use to get a sensor? the only one i have found so far is this http://www.worldcarparts.co.uk/Default.aspx?TabId=144&ProductID=1582 any help would be much appreciated. Cheers Ian.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this