Sign in to follow this  
Tommy_M

Whining At Low Speed In 1St And 2Nd

Recommended Posts

I have a 2005 Corolla T-Sport and the last couple of months it has started to whine at low speed when I am releasing the clutch after changing gear. It only happens when taking off at low revs in first gear or changing in to 2nd when I release the clutch at low speed. I am thinking it's perhaps the clutch needs attention but I don't notice any loss of power or slippages, just the noise and just at low revs. Anyone got any ideas? I was thinking clutch or flywheel but I'm not too sure.

Share this post


Link to post
Share on other sites

Hey i had a similar problem with a corolla i used to own and it was the clutch release bearing/thrust bearing

Share this post


Link to post
Share on other sites

Hey i had a similar problem with a corolla i used to own and it was the clutch release bearing/thrust bearing

Is that a major job to fix or a diy one?

Share this post


Link to post
Share on other sites

you woulh have to remove gearbox so you need a bit of experience

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this