Sign in to follow this  
Steven252

E11 Window Switch And Sunroof Problem

Recommended Posts

This ones absolutely stumped me, a couple of nights ago i went to my car and the drivers window wasnt working. The little red led that lights up in the switch is no longer lighting up on egnition either. Now at the point the passanger side still worked on both switches. I hadnt tried the sunroof to check at this time. So ive pulled out the drivers window switch to see if it was that but it looks ok internally. So ive put it back in and now i have neither window working nor does the sunroof now work.

Ive checked all the fuses and non are gone (which one is the window one??)

Anyone know if the drivers switch is gone wether sunroof still works or not? I now the passanger switch wont if its not plugged in??

Share this post


Link to post
Share on other sites

This ones absolutely stumped me, a couple of nights ago i went to my car and the drivers window wasnt working. The little red led that lights up in the switch is no longer lighting up on egnition either. Now at the point the passanger side still worked on both switches. I hadnt tried the sunroof to check at this time. So ive pulled out the drivers window switch to see if it was that but it looks ok internally. So ive put it back in and now i have neither window working nor does the sunroof now work.

Ive checked all the fuses and non are gone (which one is the window one??)

Anyone know if the drivers switch is gone wether sunroof still works or not? I now the passanger switch wont if its not plugged in??

Hmm now that is pretty freaky. What you mean by little red led? Not sure if im any help at all but if i roll both windows up at the same time the drivers gets to a certain point then goes back down. So there must be a link from driver switch of driver window to passenger. Probably wont help you though. :(

Share this post


Link to post
Share on other sites

Have you checked the window lock switch? That could have malfunctioned?

Share this post


Link to post
Share on other sites

Ah sorry dude, the red led i mean is the one that i replaced the green one with. U know where the auto part on the switch lights up with ignition - its not lighting up at all.

Ive ordered a new switch to try, it should be here tomorrow. I doubt itll work as ive got a feelig something blown :(

As for the drivers side. It goes back down when it feels resistance in the window. Its got to as its a fail safe for the one touch button. Otherwise if something got jammed it would burn the motor out ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this