Sign in to follow this  
Jimbog

Chrome Exhaust Finisher - Makes Pronounced, Unflattering Noise!

Recommended Posts

Hi

I had a chrome exhaust finisher fitted recently. The exhaust now makes a really annoying rattle/chugging noise at certain revs when decelerating and also after pressing accelerator when idle (if you see what I mean). The exhaust did not make that noise pre-finisher.

Interestingly, I drove a brand new Aygo courtesy car the other day with an exhaust finisher and that too made the same noise but it was not as pronounced. Enquired at Marshall Toyota Peterborough and they said there was nothing they could do with mine (wasn't any fault found).

Can anyone advise?? I can't believe i'm the only one affected by this!

Thanks

Jimbog

Share this post


Link to post
Share on other sites

Did you fit this yourself? Try tightening the screw that clamp onto the Exhaust, if this does not work try purchasing some exhaust wrap tape E Bay, wrap it around your exhaust where the chrome finisher sits then re-fit the chrome finisher, this will stop the vibration.

Share this post


Link to post
Share on other sites

Hi Deggs, thanks for replying. Yes I did fit it myself according to the official toyota instructions - hence I used some very strong heat resistant glue to secure the threads on place onto the exhaust pipe! :-( so I probably won't be able to get the thing off again. Do you think it could be something to do with the (bad?) design of the finisher I.e. it has a 'lip'. I say this because the best way I can describe the noise is that it's like a horse snorting!!??!! .. So maybe it has something to do with airflow? Finally, it doesn't sound when the engine is cold - but only after a minute or two of warming up/driving.

Thanks in advance!!

Share this post


Link to post
Share on other sites

LOL like the horse bit, when the pipe heats up its obviously expanding causing the Snorting noise, put on some heat protective gloves and see if there is some movement on the chrome finisher when its hot, if it has try removing it .

Share this post


Link to post
Share on other sites

Yes its defo air flow from within the pipe causing it to reverberate against the exhaust chrome finisher, the glue is used to stick it to the pipe but the pressure and heat are causing small gaps between the surface's causing that strange noise.

Share this post


Link to post
Share on other sites

Thanks Deggs very much appreciated. I wish you worked at the Toyota dealer I went to! I've got to the to find time myself to look aT it now...and buy some heat protective gloves!

Share this post


Link to post
Share on other sites

Deggs or anybody in the know please! - which make/brand of exhaust tape would you recommend please? .........

Share this post


Link to post
Share on other sites

do's not matter what brand but put gum gum exhaust putty on pipe first then wrap the exhaust wadding'/tape around,let dry till hard,yes you can let car run to dry putty.jobs a good one...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this