Sign in to follow this  
scottyd74

Hesitation On Hard Acceleration

Recommended Posts

Hi ther I got a 2003 celica vvti 140 problem I have is when hard accelerating the car feels like its holding back service been done maf cleaned throttle body stripped and cleaned no vacuum leaks kinda getting stuck now any help or advice would be appreciated cheers

Scotty

Share this post


Link to post
Share on other sites

Anyone that can help?

Share this post


Link to post
Share on other sites

Where in the rev range do you think it starts hold back?

Does it have an induction kit or any alterations to the airbox?

Share this post


Link to post
Share on other sites

No car is standard as is air box new air filter fitted on service I'd say its between 3.5 to 5.5 thousand rpm you notice it

Cheers scotty

Share this post


Link to post
Share on other sites

You reach max torque at about 4300 revs (I believe), but it should still feel fluid past that point.

Have you tried resetting the ECU?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this