Sign in to follow this  
cancun

My Hilux 2.5 4X4 Common Rail Starts And Stops

Recommended Posts

Hello everibody: Can anyone heard about a hilux 2,5 common rail that stars and stops at 2 sec? That my trouble. what can be the problem ?

cancun

Share this post


Link to post
Share on other sites

Fuel ? have you tried pumping primer on top of the fuel filter ?

Share this post


Link to post
Share on other sites

Thanks for your reply. Yes, that is a good first solution and I did it often, but is showing me that the problem can be the fuel when starts because then the truck goes normally with all power.

Share this post


Link to post
Share on other sites

Is the problem only with the first start of the day ?

Glowplugs have you checked them ? try preheating a couple on times before trying to start

Share this post


Link to post
Share on other sites

Thanks, I could solve the trouble getting a new stronger Battery, the old one was a 75 Ah and the new is 90 Ah , today 5 am it started very well with 10 degrees celsius. Isn't amazing? Maybe that flow valve at common rail ,that is an electrovalve, didn't be opening or better could shut a seconds later for decreasing voltage. Thanks very much all people there!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this