Jump to content
Do Not Sell My Personal Information


Engine Noise D4D


john11k
 Share

Recommended Posts

Hello. I own a 07, avensis D4D strata, 2ltr, Diesel, i have owned the car past two years, i bought it with 100k aprox, and now has 276k, i have noticed that it has engine noise, sounds to me like tappets, ( im not to well up on engines ) i service the car every 6 to 7 thousand miles, it seems to be more noisey in mornings cold, and a low gears in traffic, none or little smoke , and dosent use any oil,

Any ideas , Thanks, John

Link to comment
Share on other sites

Sounds like its just a bit of normal wear and tear on a 276k motor, its gotta be a gudden ;)

Link to comment
Share on other sites

Dave, Thank you, yesit is a gudden, but i do look after it well, service every 6 / 7k, sometimes on 5k, the noise has been there ( slightly ) since i bought it, but over the past two years has got a bit louder, ! it seems worse when it cold, and when i put my foot down in second and third, i thought it might be somethoing with injectors or timing chain, but im just guessing, also when im cruising in 5th or 6th, can hardley hear it,

Thank you for reply, best wishes, John

Link to comment
Share on other sites

mine (2004 - D-4D) has always sounded a bit 'tappy' when cold ... but soon calms down once warm .... so I don't worry too much

if it's always noisy, the n it might be a sign of wear.

Link to comment
Share on other sites

Dave, Thank you, yesit is a gudden, but i do look after it well, service every 6 / 7k, sometimes on 5k, the noise has been there ( slightly ) since i bought it, but over the past two years has got a bit louder, ! it seems worse when it cold, and when i put my foot down in second and third, i thought it might be somethoing with injectors or timing chain, but im just guessing, also when im cruising in 5th or 6th, can hardley hear it,

Thank you for reply, best wishes, John

Its inevitable your going to have some wear but it also sounds like a bit injector rattle which all D4D have, even the new ones.

Have you run some decent fuel system cleaner through lately ?

Link to comment
Share on other sites


My guess is an injector is out of spec, classic symptoms for a dodgy injector

Kingo :thumbsup:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share





×
×
  • Create New...




Forums


News


Membership