Sign in to follow this  
Dean32

Celica Gen 7 Random Unplugged Wire

Recommended Posts

Hi,

My handbrake when on is not giving me the (!) light on my dash, so when seein if the handbrake wire was connected i found a random cable and wanted to know, should this be connectred somewhere?

Handbrake cable was plugged in but still isnt working... :/

Anyone tell me what this cable is or know why the handbrake warning light is not showing?

post-133516-0-00393800-1389631639_thumb.

Share this post


Link to post
Share on other sites

An update, when I first start the car and the handbrake is on it shows the (!) But when I take the handbrake off and put on again it doesn't come back on...?

Share this post


Link to post
Share on other sites

Further update, handbrake warning light now fully functional, must have been a loose connection. Still dont know what the unplugged cable is though if anyone knows??

Share this post


Link to post
Share on other sites

Might be to do with the traction control box, it's usually located under the handbrake.

Share this post


Link to post
Share on other sites

Hi Colin,

Thanks for the reply, My TRC and VSC lights are on currently, maybe its just a loose wire! I see if I can see anything there.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this