Sign in to follow this  
tuhi80

Yaris Verso 1.3 Stalling Right After A Cold Start

Recommended Posts

Dear forum members,


I have a 2004 Yaris Verso with 1.3 liters 2NZ-FE engine. It's RHD if that makes any difference. Problem is that with very cold temperatures (-15 celcius) the idle is fluctuating so badly it often stalls. So I may have to restart it once or twice before it stays running (I haven't actually tried to keep it running yet by pressing the gas pedal).


I tried to find any intake leaks but none were found. My guess is that the idle speed control valve is faulty. I tried to spray it with start pilot spray to wash it (didn't have any throttle body cleaner at hand) but it didn't make a difference. Probably to clean it properly you would have to remove the ISC. If the problem is ISC, can it be cleaned or do I have to replace it?


Any other ideas what could cause the idle fluctuation? When it warms up it idles perfectly. There are no error codes and also the emissions are within the norms.


Thanks for your help!

Share this post


Link to post
Share on other sites

The reason why I am suspecting ISC is because it seems to have coolant tubes going into it so the operation is likely to be affected by the coolant temperature. Could somebody clarify how it works?

Share this post


Link to post
Share on other sites

Read these from Car Mechanics..

post-22688-0-19107700-1390226001_thumb.j

post-22688-0-37816500-1390226024_thumb.j

Share this post


Link to post
Share on other sites

Thanks for a quick reply Madasafish. This could solve the problem although the symptoms are different.

So are there both the stepper motor which is driven electrically and waxostat which is controlled by the temperature? And these two systems are not connected?

Before I start opening the coolant tubes, I would like to ask if there is a way to electrically measure the condition of the stepper motor? Any ohm readings or similar? Can I measure the driving signal somehow (I only have a multimeter though)?

The fluctuation is now quite rapid. I wonder if the waxostat could react so fast? Thanks!

Share this post


Link to post
Share on other sites

Another question. In your opinion, can I just leave the tubes attached to the ISC valve and take off the tube ends from the engine block and blow compressed air into one of the loose ends so that any crap will come out of the other loose end? Is this safe for the valve? Sorry my technical English is not perfect, I am not sure what the article means by air line.

I forgot to mention that I have changed the coolant around 200 000 km. I just let the coolant drain from the radiator bottom but I didn't rinse it with water or anything before filling up. The car has all and all 236 000 kilometers now.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this