Sign in to follow this  
marioc

P0420 Following Catalytic Converter Change ...

Recommended Posts

I have become a victim of the dreaded 'Check Engine Light' with a P0420 fault code following the replacement of my front exhaust pipe (including cat)! The replacement cat was 'type approved'. Ever since, I have been plagued by P0420. So far, they have replaced the cat again (in case the first one was faulty!) .. no joy CEL again. Now they have changed the after cat lambda sensor .. still no joy !!

Has anyone else been through this 'pain' ??

Is there anything else that :

a. might have been disturbed in fitting the new cat, that I should get the fitters to check?

b. I should be checking or doing ?

c. would the ECU need re-calibrating following the cat change ?

d. Is there any value to running a few tanks of Shell V Power fuel or adding some fuel injector cleaner ?

Any views or help would be much appreciated, as it's beginning to drive me mad !!

  • Like 1

Share this post


Link to post
Share on other sites

Did you clear out the rest of your exhaust when the original cat was at fault. You may have a blockage in one of your rear boxes further down.

Share this post


Link to post
Share on other sites

Any good quality cats available?

Other than the €1300 Mr T wants :blowup:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this