Jump to content
Do Not Sell My Personal Information


2006 Corolla SR 2.0 Losing Power


JA3
 Share

Recommended Posts

Hi all,

My corolla has started losing power across various gears, whether driving down the motorway in 5th or taking off in 1st. if it happens in 1st for example, I get a shuddery take off, but it only seems to last for a few secs in 1st or 2nd gears. In 5th driving at 60 mph, if it happens, the car won't accelerate any further but will very gradually slow. The issues seems to last about 20 - 40 seconds in higher gears. then the car starts answering to the accelerator again. The rev counter doesn't move anywhere no matter how far I push the accelerator. I am assuming at this point it isn't a clutch problem. There doesn't seem to be any pattern to it that I can identify, only that it will only ever occur when the car is completed warmed up. 

I had a very similar problem with my 1996 2.0 corolla and replacing the fuel filter solved that. I have replaced the fuel filter but it's still happening. From what I can tell it seems to be an issue getting fuel into the engine (a bit limited in my mechanical knowledge). 

Hoping someone can offer some advice. 

Thanks,

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share





×
×
  • Create New...




Forums


News


Membership