Jump to content
Do Not Sell My Personal Information


Problems with turbo


Recommended Posts

I have had problems with the turbo twice in the last six months. Initially it was thought a pressure sensor had gone, the pressure sensor was replaced and the car started to run OK but after 600 miles the turbo is giving more problems although it's not clear what is wrong with it?

 

Has any one had any similar issues with their verso? If so how did they get around it?

Thank You

 

Link to post
Share on other sites

On 3/6/2021 at 10:25 PM, Muh said:

I have had problems with the turbo twice in the last six months. Initially it was thought a pressure sensor had gone, the pressure sensor was replaced and the car started to run OK but after 600 miles the turbo is giving more problems although it's not clear what is wrong with it?

 

Has any one had any similar issues with their verso? If so how did they get around it?

Thank You

 

Further to my message above I have been told it could be DPF filter that could be on it's way way out, has anybody experienced this problem with any of their diesel vehicles?

How did you over come it?

Link to post
Share on other sites

The engine management lights keeps coming back and the vehicle lacks power. The garages I have been to have been unable to diagnose what the exact problem is, they believe it could be boost sensor or ECU fault but not sure. Previously a pressure sensor on the turbo was replaced but the light came back on only after 600 miles.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...




Forums


News


Membership