Jump to content
Do Not Sell My Personal Information


Heaterfan Speed Control Doesn't Work


kiMARCO
 Share

Recommended Posts

The Fan of the heater system only turns when set to maximum speed, in the other settings it just doesn't spin. I checked the dialswitch, this seems to work fine so it must be some regulating unit.

Also the AC is turned on in all settings appart from off, so that works well, just the fan doesn't turn.

Anyone can tel me where to find the "black box" which is operating the fan and needs replacement(s) ?

Link to comment
Share on other sites

  • 3 weeks later...

The Fan of the heater system only turns when set to maximum speed, in the other settings it just doesn't spin. I checked the dialswitch, this seems to work fine so it must be some regulating unit.

Also the AC is turned on in all settings appart from off, so that works well, just the fan doesn't turn.

Anyone can tel me where to find the "black box" which is operating the fan and needs replacement(s) ?

i had an almera with the same problem, it is a little circuit board called a heating resistor it controls fan speed by reducing current to slow the fan down. they tend to burn out as they heat up whilst reducing current. nissan replacement one cost me 30 quid easy to fit just plugd in

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership