Jump to content
Do Not Sell My Personal Information


Clutch Problem


T-Bar_Steve
 Share

Recommended Posts

Had a new clutch fitted bout 4 weeks ago, mines the rev2 n/a and i bought the standard clutch kit from fensport, problem being that the clutch is slipping but only pulling away at about 3-4,000 rpm or higher, it doesnt slip at any other time just pulling away, the garage that did it have had a look and cant seem to find wot the problem is, its not a hydraulic problem as the pedal is 2 smooth, the only thing they can suggest is that it is a weak or faulty pressure plate, can anyone shed any light on this problem or has anyone had any problems with clutches from fensport?

Cheers,

Steve

Link to comment
Share on other sites


Had a new clutch fitted bout 4 weeks ago, mines the rev2 n/a and i bought the standard clutch kit from fensport, problem being that the clutch is slipping but only pulling away at about 3-4,000 rpm or higher, it doesnt slip at any other time just pulling away, the garage that did it have had a look and cant seem to find wot the problem is, its not a hydraulic problem as the pedal is 2 smooth, the only thing they can suggest is that it is a weak or faulty pressure plate, can anyone shed any light on this problem or has anyone had any problems with clutches from fensport?

Cheers,

Steve

What type did you buy and does the clutch pedal feel very light, and where is the bite on the pedal.

R.

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership