Jump to content
Do Not Sell My Personal Information


Electrical Problem?


GnzYza
 Share

Recommended Posts

Hi All,

On my 99 1.8 Avensis, the interior light went, central, etc....PROB was due to DOME fuse!!

But my interior light blew a bulb a few days later, THE DOME FUSE is ok thou. ANY IDEAS!!!

Also my orange ecu light comes on occasionally??

And sometimes my temp needle dont work, unless i wait a while with the ignition on before starting.

Is this an earth problem or something any one had this problem and found a SOLUTION??

I know the ecu warning light must be summat to do with a senosor or something out.

where are the bunch of earthing contacts located??

All help much appreciated.

Link to comment
Share on other sites


Pop a new bulb in. It won't really blow because of another problem elsewhere.

Sticky guages have been known on the Avensis.

You need to find out why the check engine lamp is illuminating. Read off the fault code, and see what it is. This may give you a clue.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership