Jump to content
Do Not Sell My Personal Information


Yaris T-sport Sports Cat


M1cha3l
 Share

Recommended Posts

Hi everyone I am after some advice if possible. I recently had a sports cat fitted to my Yaris T-sport and everything was great for about half an hour, then the Engine management light came on. I was wondering if anybody else has fitted a sports cat and had the same problem or if it is just a coincidence that the light came on after fitting the sports cat. I was thinking that maybe the light has come on because the emissions are different to standard with the sports cat but if that is the case I can't see how to get round the problem. I can't be the only one who has fitted a sports cat though so that's why I have come here for help.

Thanks in advance guys.

Link to comment
Share on other sites


I don't know a great deal about sports cats but how many substrates does your's have 100 or 200? 100 gives the best gas flow but are not suitable on modern obd ll diagnostic systems like the ones found in the Yaris.

To be sure of what the fault is you first need to find out what the error code is as it could just be a coincidence.

Link to comment
Share on other sites

I don't know a great deal about sports cats but how many substrates does your's have 100 or 200? 100 gives the best gas flow but are not suitable on modern obd ll diagnostic systems like the ones found in the Yaris.

To be sure of what the fault is you first need to find out what the error code is as it could just be a coincidence.

Hi thanks for your reply. I'm not sure how many substrates it has as i got it from ebay from someone who had taken it off their T-sport. They said it was an envy sports cat for Yaris T-sport so presumed it would be compatible. The garage that fitted it plugged it in to find the fault code and they said it was the rear lambda sensor. I just don't know whether they have maybe damaged the sensor or if the sensor is picking up readings from the new cat that are not within the manufacturers default limits.

Link to comment
Share on other sites

The engine management light has come on as your lambda sensor is reading something wrong.

If it's a non standard cat - and if cheap - it's probably US.

And soon it will be illegal to fit cats that are not type approved .. £5k fines for offending garages.

Link to comment
Share on other sites


Thanks everyone for all the replies. I decided to buy an OBDII Scanner to find out for myself what the problem was and it came back with P0141 O2 sensor heater circuit malfunction. I am now thinking that the garage may have damaged the O2 sensor or not re-fitted it correctly causing a short circuit so hopefully just a new O2 sensor will sort out the problem.

I notice that a few of you are quite local in the Leeds/Bradford/Huddersfield area, do you have any recommendations for a decent local garage? I don't think I will be returning to the place that fitted my CAT.

Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership