Sign in to follow this  
Thanny

Tappet Noise On Warm Engine Need Ideas 03 Hilux

Recommended Posts

Hey all, my 03 turbo deisel hilux has a problem and need some ideas

i have a ongoning tappet noise coming from the engine. Was taking off went from first to second and the problem arised. A large grinding big ends noise (just went) started coming from then engine baY. i thought some thing was wraped around the tailshaft hiting the bottom of the cab but it was not to be. we have played around and tested most sensors relating to the thought problem with the multi meter but they all check out. it did sound like the big ends but now sounds tappets. its not blowing smoke. and only starts making the noise when the engine is hot. on start up it sound normal. as it is turned off the noise is a ticking over noise (if that makes sense) the injectors have been checked and are fine. they are tourqed up to specs. the belts are all new as we changed them coz we had the radiator out and cleaned it. the timing belt is fine and has not sliped a tooth. i have heard of a cracked exhaust manifold which we havnet check yet which will do tomorow but dont hold to much hope. Have run out of ideas and thinking it is fuel related. wondering if anyone has ran into this problem or has any ideas. and thoughts would be much apreciated as dont wanna take it in. yet.

thanks for any feedback

Share this post


Link to post
Share on other sites

Hi, I know this thread is old but I've got a hiace with extremely similar sounding symptoms. The noise sounds like a loose tappet or a duff injector and is only really pronounced when the engine is warm. Driving on light throttle is when it's at its worst.

Did you find the cause? I'm keen to know!

cheers

Ben Lord

Share this post


Link to post
Share on other sites

I have exactly the same noise on my 02 D4D. It does my head in and have to keep changing my speed/throttle to stop it. Please help me to keep my sanity! Anyone??

Share this post


Link to post
Share on other sites

the forum i usually frequent has had this problem come up several times,

the usual answer is, the d4d engine seems to have incredibly noisy injectors, if your motor is new enough you can take it back to the dealers

some people have had luck using comma diesel magic

i have tried it in mine and it did make a difference, defiantly going to try another bottle

Share this post


Link to post
Share on other sites

i pour about 300ml of 2 stroke Oil in the tank every time i fill her up :yes:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this