Sign in to follow this  
stevensonnz

Hilux 1990 3Y Popping Noise

Recommended Posts

Truck was running sweet and then i changed the spark plugs with brand new ones of the same brand and same code. I also set the gap between the top of the spark plugs and the elecrode to 0.8mm.

Now when i start the truck up, there is a popping sound coming from the engine and its isnt idleing well. There is also a rich petrol smell when the truck is turned on.

Any help on diagnosing the problem?

Thanks

Share this post


Link to post
Share on other sites

it looks like the sparks have become wet after first revolutions.

take then off and dry out + try again

regards / igor

Share this post


Link to post
Share on other sites

Truck was running sweet and then i changed the spark plugs with brand new ones of the same brand and same code. I also set the gap between the top of the spark plugs and the elecrode to 0.8mm.

Now when i start the truck up, there is a popping sound coming from the engine and its isnt idleing well. There is also a rich petrol smell when the truck is turned on.

Any help on diagnosing the problem?

Thanks

You haven`t put one of the plugs in cross threaded have you ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this