Sign in to follow this  
rob virgo

Tspirit D4D Not Starting

Recommended Posts

Car was getting slower to start for weeks , would start ok cold first thing in the morn but after a run or warm it would take a few try's

Car would spin slowly and not catch or even slow to a stop like a flattened Battery, leave for ten secs and next try would spin at normal speed and may or not start.

Starter suspected by auto elec so he rebuilt a Toyota starter I had, replaced bendix.

Car now spins much quicker but it won't start at all, will start on a small bump start and drives ok, elec said starter is perfect but noticed a leak on one injector

Any ideas , Igor maybe 😄

Share this post


Link to post
Share on other sites

hello

is batery ok ??? tested???

are glow plugs have the same resistance ?? and have no el signal lose?

SCV -- you should check its control coils to have resisnace in limits as per manual;

fuel filter --- what is his fate? when it was last changed?

I would appreciate you to send a video of starting up trials.

cheers/Igor

Share this post


Link to post
Share on other sites

Battery seems ok, gave it a full charge last nite and tried to start car cold,as expected it started ok as before.ill video it now gr you as didn't leave it heat up...

Don't have a manual,can I check plug resistance with meter while still in place and on troll coils ??

Would appriacte a quick how to , fuel filter is about 10k only.....

Share this post


Link to post
Share on other sites

shsould the engine stalls after have started then you should change fuel filter

and try again.

in details -- the fuel remained inside the filter housing is well enough for starting up. but after it is clear the engine must to stall cos the filter element is not able to pass diesel thru itself

Share this post


Link to post
Share on other sites

as to tester ---- please fly on the forum page by page to find topic connected with lalck of power or similar -- Mr petespirit has hang drawing how to measure

Share this post


Link to post
Share on other sites

Will try a new filter later, hope it starts after I collect filter as car will be hot after drive to mister T

Video of cold start here

Share this post


Link to post
Share on other sites

New link, first one incorrect

still does not work

Share this post


Link to post
Share on other sites

- cranking must be faster;

- after have started up -- it works ok with responsible revving

check with voltage coming to thebattery leads and check with density of acid -- it looks like the Battery starts to flat

Share this post


Link to post
Share on other sites

do you depress clutch pedal or you have an A/T ??

Share this post


Link to post
Share on other sites

Sometimes I press clutch , should you do this

you should deppress it always you start it

charging voltage is OK

try to start when pedal is depressed -- the crancing must be faster

Share this post


Link to post
Share on other sites

does batery have green indiicator of its status ?

check with acid density

Share this post


Link to post
Share on other sites

No indicator but will get Battery supplier to check,it's about 1 year old only..doesn't seem to spin faster with clutch in ??

Share this post


Link to post
Share on other sites

No indicator but will get battery supplier to check,it's about 1 year old only..doesn't seem to spin faster with clutch in ??

you must to examine both starter and Battery -- one of them gives you a head ache

you have one outcome as slow cranking !!!! also check with glow plugs -- they will not help when Battery has given up

Share this post


Link to post
Share on other sites

After a full overnight charge it seems to be ok on to starts now but funny noise from starting motion.

I have to admit I removed a Battery isolator I was using to reset dash warning lights easily every two weeks....

This may have been restricting the voltage...

Tks to everyone esp ignored for the great help on all issues in this forum....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this