Sign in to follow this  
Southern Softy

2019 RAV 4 - Which Touch 2 Navigation To Download

Recommended Posts

I collected my new leased RAV4 on Friday and today I tried to set up the Touch 2 navigation as the supplying dealer did not set it all up for me when I collected the car. I called into my local dealership hoping to get some help and there tech guy was not up to speed on the new RAV4, not ideal but he did offer some help so not a wasted visit.

As I am new to Toyota I have not found the process that easy to be honest but think I am just about sorted now but just wanted some reassurance on the version I have loaded to the car.

I have set up a Toyota ID so I can now do quite a few things on line, alter a few settings, down load apps etc. I seem to be able to get the TomTom live sat nav with my phone acting as the wi-fi hot spot so just need to clarify I have downloaded the correct Touch 2 version.

I was told to download the “ Toyota Touch 2 Plus 17 MM Toy “ satnav version as listed on the Toyota Website page, so can anyone confirm this is correct,

many thanks

Share this post


Link to post
Share on other sites

The original (~2011 >) was Touch & Go, the later one is Touch2 with Go & you will have an updated version of that also known as MM17 ...

Share this post


Link to post
Share on other sites

Hello. I have the same problem. Registered device is Toyota Touch 2 Plus 17 MMToy, but there is no such device listed on Toyota's page for device update... Do you have a link to the page where this exact device is listed with updates for it?

Share this post


Link to post
Share on other sites

Are you in the U.K. ? It may be different in other countries.

Share this post


Link to post
Share on other sites

No, I'm in Bosnia, but vehicle is from the UK. However, after device registration online (via WiFi in the car), information at the co.uk portal indicate this device model - Toyota Touch 2 Plus 17 MMToy.

Unfortunately, there is no such a model at any Toyota portal... From previous experience with my Corolla, factory installed maps are outdated. My current navdb_version in new RAV is A36_4 (whatever it means) and navigation is v.1520.

 

Share this post


Link to post
Share on other sites

I've tried to pair model Toyota Touch 2 with Go (CY17) with my device ID, just to check is it the same because of similarities in its name and look on the picture, but itćs not compatible.

Share this post


Link to post
Share on other sites

the newer systems arent touch 2 - thay are based on a different platform,  does it support andriod auto and Apple play ?

If you go into the general settings and then system info it will give you the part number

have a look here to ID your system https://www.toyota-mapupdates.eu/Shop/Index

Share this post


Link to post
Share on other sites

Yes, I have that, both model ID and Parts No. but it's in format DCU: XXXXX-XXXXX and MEU: XXXXX-XXXXX. There is nothing even similar to Touch 2 etc.

But, as I said already, after I connected device via WiFi, at toyota.co.uk portal under My vehicles I can see device name, and it is - Toyota Touch 2 Plus 17 MMToy.

 

Edit: Thank you for the link, I was there already, and there is no this device. It's the same at toyota-tech.eu or any other portal. This is the closest one - Toyota Touch 2 with Go (CY17) (looking at the image), but it's not this one

Share this post


Link to post
Share on other sites

Its more than likely there isnt a update for it, the maps are usually a year behind, some maps update ever 3-4 months and should be on the portal

if its yearly maps the data is collected in Q1 or 2 what can be anthing upto 9-12 months old then its released in Q3 or 4, The maps are Here (formaly Navteq)

 

 

Share this post


Link to post
Share on other sites

Actually, and according to experience with Corolla in 2016, this system don't have acoustic warning for speed cameras at the moment. Same as in Corolla. And after updating maps and software, it started to work. I hope it will happen here too 🙂

Share this post


Link to post
Share on other sites

Den

in the U.K. for the new RAV4 from model year 2019 you need is  - Toyota touch2plus17MM toy. If you are not in the U.K. you may not be able to get this version.

cant help further, sorry

Share this post


Link to post
Share on other sites

Yes, and that's the version of my device. But, where to find updates for this?

Share this post


Link to post
Share on other sites

OK. Just received info from Toyota support, confusion solved. So, this can be helpful for all of you with this new multimedia-nav devices.

Correct map & software updates for the Toyota Touch 2 Plus 17MMToy are those named Toyota Touch 2 with Go (CY17) .

  • Thanks 1

Share this post


Link to post
Share on other sites

Further complicated by the fact that the on-line system won't cooperate until more than 120 miles have been covered. Something to do with setting first use date.

Share this post


Link to post
Share on other sites
On ‎7‎/‎15‎/‎2019 at 9:19 PM, Southern Softy said:
I collected my new leased RAV4 on Friday and today I tried to set up the Touch 2 navigation as the supplying dealer did not set it all up for me when I collected the car. I called into my local dealership hoping to get some help and there tech guy was not up to speed on the new RAV4, not ideal but he did offer some help so not a wasted visit.

As I am new to Toyota I have not found the process that easy to be honest but think I am just about sorted now but just wanted some reassurance on the version I have loaded to the car.

I have set up a Toyota ID so I can now do quite a few things on line, alter a few settings, down load apps etc. I seem to be able to get the TomTom live sat nav with my phone acting as the wi-fi hot spot so just need to clarify I have downloaded the correct Touch 2 version.

I was told to download the “ Toyota Touch 2 Plus 17 MM Toy “ satnav version as listed on the Toyota Website page, so can anyone confirm this is correct,

many thanks

I have not checked my Touch 2 Plus since getting my Rav4 but it seems to work well, voice control is good for making calls etc. But something I did, I was sent an app from my dealer 'MyToyota' before I got the car. Registered with this MyToyota. Eventually I got my car and added the car VIN number to this MyToyota app. The app then told me all about my car, gave handbooks etc.

I then went into the car and started the wifi and registered to MyToyota added email. and password. Now something changed, I got load more DAB radio stations, so I assume this loaded up the latest drivers.

Now last year I got the Rav4 2018 and there was instruction for doing this in all the paperwork given to me. But for the Rav4 2019 I have not seen this instruction anywhere.

Share this post


Link to post
Share on other sites

Here I am again... Unfortunately seems I started to celebrate too early...

Namely, after support guy confirmation that Toyota Touch 2 Plus 17 MMToy is the same as Toyota Touch 2 Go (CY17) I've tried to update my maps in RAV4.

The result was that system validated files on USB stick, offered me to update maps to the latest version 2019.1 and then provided Request Code. But, that code wasn't compatible with my Device ID, which probably means that these two devices (MMToy & CY17) are not really the same... I'we tried all via toyota-tech.eu portal, as I always did for my Corolla, end received this error. 

Guys in local Toyota service also tried, but with the same result.

If someone succeed to update this Toyota Touch 2 Plus17 MMToy device/maps in RAV4 2019, please share details. Thanks in advance.

Share this post


Link to post
Share on other sites

Den,

the mmtoy is the one you need, I have this and the 2019 1 mapmupdate. You get that from the e store, down load it to a usb and then upload to your car

Share this post


Link to post
Share on other sites

Hi again. Thank you all for advices, but seems nothing work for me here...

When I go to eStore and choose 2019.v1 Map update, I cannot download it because the system leads me to purchase it (yes, it's free and I also see it) and at the end it tells me that "Item is free and cannot be purchased". 😞

So, my vehicle has passed over 300km and should be OK for updates. Also I was connected it to the WiFi and installed eStore app, so FUD should be also set now.

But, seems I cannot use eStore because all I see is info about expiration date of the app, but there is no eStore icon anywhere under the Apps section.

This morning I was tried again, via toyota-tech.eu, but after entering all codes (Device ID and Request code shown on the screen after validation of the files on USB and offering me to update system to 2019.v1), I'm still getting the same Error - request code not compatible with Device ID....

Just preparing my gun to shot something of this 😄

Share this post


Link to post
Share on other sites
On 9/19/2019 at 2:11 PM, Southern Softy said:

Den,

the mmtoy is the one you need, I have this and the 2019 1 mapmupdate. You get that from the e store, down load it to a usb and then upload to your car

Southern Softy,

Yes, I know this, but simply cannot find this device listed anywhere, at any Toyota portal...  Do you have some link where this exact MMToy device is listed? All I can see is Toyota Touch 2 & Go CY17... It looks like MMToy, and guys from support told it's the same device, but...

Edit: Just realized something - is it necessary to Register vehicle at portal (with that Version code) in order to access download section...?

Share this post


Link to post
Share on other sites

You have to Register your vehicle, reg number and VIN number 

Share this post


Link to post
Share on other sites

I did, days ago...Reg. No, VIN and MM device. All registered. I'm an IT for more then 20 years, so you can imagine how all this frustrating me, especially because nobody from Toyota cannot provide answer why I'm getting this incompatibility error... Talked to domestic guys, toyota.co.uk., toyota-tech.eu... No resolution...

There is only one more thing at the portal for which I'm not sure what is it and does it have any relation with this updating maps issue - Section named "Connecting your car", with description "Hi, you have a car connected. In order to use all the online services available for your car, you must first go to your dealer to have them activated."

What is this mean and what additionally they have to activate here?

Share this post


Link to post
Share on other sites

Den,

That is correct, a dealer, any dealer needs to register your car. My supplying dealer did not do this and I had the same issue so took it to another who did register it for me, from memory it hen became active overnight,

hope that may help

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Club Hybrid Poll

  • 219 Hybrid Reliability

    1. 1. If you were to consider buying a Hybrid model over 5 years old, would you be worried about the reliability of the Hybrid system?


      • Not really as Hybrid systems are always reliable
      • Not if it had a Manufacturers Warranty on the Hybrid system
      • I would not buy a Hybrid model over 5 years old